voreingestelltes Lister- Layout wird nicht geöffnet

Aktuelle Version: 12.6 (09.06.2017)
Alles zum Thema Directory Opus
Antworten
photona
Beiträge: 25
Registriert: 7. Jan 2006 14:54
Betriebssystem: Windows 10 x64
Produkt: DOpus 12.6 X64 B 6369
Version DOpus: Pro

voreingestelltes Lister- Layout wird nicht geöffnet

Beitrag von photona » 23. Dez 2016 14:42

Hallo liebe DOpus- Nutzer,

da ich lieber mit der Tastatur als mit der Maus navigiere, öffne ich einen neuen Lister oft mit [Windowstaste+E]. Leider wird dabei das voreingestellte Lister- Layout ignoriert. Bei den anderen Methoden zum Öffnen eines neuen Listers (Doppelklick auf Desktop, Klick aufs Taskleistensymboll usw.) erscheinen die Lister ordnungsgemäß im voreingestellten Layout.

Wie kann ich Directory Opus dazu bewegen, auch bei Aufruf mit [Windowstaste+E] das voreingestellte Layout bzw. den Standardlister zu verwenden?

Vielen Dank im Voraus!

Benutzeravatar
Nobmen
Boardbetreuer
Beiträge: 2818
Registriert: 26. Jun 2004 08:48
Betriebssystem: Win 10 Home/Pro 32/64bit
Produkt: DOpus 12.x + Betas
Version DOpus: Pro

Re: voreingestelltes Lister- Layout wird nicht geöffnet

Beitrag von Nobmen » 23. Dez 2016 16:43

die erwähnten möglichkeiten haben nichts mit dem standardlister zu tun!
dieser muss einzeln gespeichert werden damit dieser das behält
(hab seit der 8er nicht raus gefunden warum das so ist!)
stelle diesen so ein wie es sein sollte und setze das
lister.jpg
lister.jpg (46.54 KiB) 815 mal betrachtet
hinweis:
diese einstellungen wird durch aufräum/verbesserungsprogramme für windows oft gelöscht!
die kennen das nicht und wird deshalb entfernt

photona
Beiträge: 25
Registriert: 7. Jan 2006 14:54
Betriebssystem: Windows 10 x64
Produkt: DOpus 12.6 X64 B 6369
Version DOpus: Pro

Re: voreingestelltes Lister- Layout wird nicht geöffnet

Beitrag von photona » 23. Dez 2016 20:14

Hallo Nobmen,

danke für Deine Antwort.
das habe ich längst alles schon probiert, der gespeicherte Standardlister entspricht meinem "default" Layout. Trotzdem wird bei Aufruf mit [Windowstaste + E] im linken Lister immer das Wurzelverzeichnis "Computer" angezeigt und nicht der im Standardlister bzw. im default- Layout eingestellte Pfad. Hatte vermutet, dass es eventuell etwas mit dem Pfad zu tun hat, der für den originalen Windows- Explorer standardmäßig verwendet wird und diesen in den Explorereigenschaften geändert. Das hat aber auch nicht geholfen, DOpus zeigt bei Aufruf mit [Windowstaste + E] immer "Computer" im linken Fenster an.

Benutzeravatar
Kundal
Moderator
Beiträge: 1337
Registriert: 20. Apr 2010 21:26
Betriebssystem: Win7 & Win 10 Pro 64 bit
Produkt: DOpus 12 x64 - Letzte Betaversion
Version DOpus: Pro

Re: voreingestelltes Lister- Layout wird nicht geöffnet

Beitrag von Kundal » 23. Dez 2016 21:05

Das Tastenkürzel Win+E ist von Windows festgelegt. Es gibt offenbar nur zwei Möglichkeiten das zu ändern:
  • durch einen Eingriff in die Registrierung kann der Hotkey deaktiviert werden. Das wird hier unter "Kombinationen gezielt abschalten" beschrieben. Danach kann die Kombination als globaler Hotkey in DOpus verwendet werden. Das bedeutet aber, dass der Hotkey nur solange systemweit funktioniert, wie dopus.exe läuft.
  • Mit einem Autohotkey-Script kann die Funktion der Tastenkombination geändert werden. Dazu muss das Script oder eine daraus kompilierte Exe-Datei ständig im Hintergrund laufen und benötigt dann keine laufende dopus.exe. Das Script würde z.B. so aussehen:

Code: Alles auswählen

#NoTrayIcon
#SingleInstance force
#E::Run %A_ProgramFiles%\GPSoftware\Directory Opus\dopusrt.exe /cmd Go LASTACTIVELISTER NEW 
Wenn du dich mit Autohotkey nicht auskennst könnte ich dir eine eigenständige Exe-Datei aus diesem Script erstellen. Ich benötige dann den genauen Pfad zu dopusrt.exe und den gewünschten Befehl, der ausgeführt werden soll.

Benutzeravatar
Kundal
Moderator
Beiträge: 1337
Registriert: 20. Apr 2010 21:26
Betriebssystem: Win7 & Win 10 Pro 64 bit
Produkt: DOpus 12 x64 - Letzte Betaversion
Version DOpus: Pro

Re: voreingestelltes Lister- Layout wird nicht geöffnet

Beitrag von Kundal » 23. Dez 2016 22:09

Hier die Autohotkey EXE-Datei in 32-bit und 64-bit. Der Pfad zu dopusrt.exe wird aus der Registrierung ausgelesen.
Der ausgeführte Standardbefehl ist Go LASTACTIVELISTER NEW. Der Befehl kann geändert werden, indem im gleichen Verzeichnis eine Text-Datei mit Namen WinE.ini und z.B. folgendem Inhalt angelegt wird:

Code: Alles auswählen

[Command]
command="Go /temp NEW"
AHK-Script:

Code: Alles auswählen

#NoTrayIcon
#NoEnv 
#SingleInstance force
SendMode Input
RegRead,DopusDir, HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\DOpus.exe,Path
IniRead,command,WinE.ini,Command,command,Go LASTACTIVELISTER NEW
#E::Run %DopusDir%\dopusrt.exe /cmd %command%
Dateianhänge
Win_E.zip
(725.64 KiB) 33-mal heruntergeladen

photona
Beiträge: 25
Registriert: 7. Jan 2006 14:54
Betriebssystem: Windows 10 x64
Produkt: DOpus 12.6 X64 B 6369
Version DOpus: Pro

Re: voreingestelltes Lister- Layout wird nicht geöffnet

Beitrag von photona » 25. Dez 2016 14:56

Danke Kundal, ich habe die Windows- Kombination in der Registry deaktiviert und DOpus die Kombi zugeordnet, jetzt funktioniert es. Danke für die Tips!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste