&-Zeichen im Button

Aktuelle Version: 12.7 (23.11.2017)
Alles zum Thema Directory Opus
Antworten
Joerg765
Beiträge: 98
Registriert: 12. Apr 2010 07:23
Betriebssystem: Windows 7 Home 64bit
Produkt: DOpus 11.3
Version DOpus: Pro

&-Zeichen im Button

Beitrag von Joerg765 » 20. Apr 2015 19:32

Ich habe einen Butto erstellt, der im Dateiamen von Dateien und Ordnern das Wort "und" mit dem "&-Zeichen" ersetzt.

Code: Alles auswählen

<?xml version="1.0"?>
<button backcol="none" display="icon" separate="yes" textcol="none">
	<label>"und" ersetzen durch "&"</label>
	<icon1>#DOpus9:favorites</icon1>
	<function type="normal">
		<instruction>Rename FINDREP PATTERN " und " TO " & " AUTORENAME</instruction>
		<instruction>@NoDeselect</instruction>
	</function>
</button>
Warum wird das "&-Zeichen" in

Code: Alles auswählen

<label>"und" ersetzen durch "&"</label>
nicht angezeigt, wenn ich mit der Maus über den fertigen Button drüberfahre ?

Da steht dann nur "und" ersetzen durch "", das "&-Zeichen" fehlt einfach. Alle anderen Sonderzeichen werden angezeigt.

Benutzeravatar
tbone
Berater
Beiträge: 405
Registriert: 22. Nov 2014 21:16
Betriebssystem: 7*64
Produkt: aktuelle Beta-Version
Version DOpus: Pro

Re: &-Zeichen im Button

Beitrag von tbone » 20. Apr 2015 20:50

Das "&" ist ein Sonderzeichen in manchen Labels und generell Windows GUI-Elementen, es sorgt dafür, dass der "_" Underscore/Unterstrich für ein nachfolgendes Zeichen angezeigt wird, was wiederum angibt, mit welcher ALT-Kombination dieses Element über die Tastatur direkt auszuwählen ist.
Ich kann es hier jetzt nicht demonstrieren, weil das Forum keine unterstrichenen Zeichen ermöglicht, helfen könnte jedenfalls zweimal "&", so -> "&&".

Joerg765
Beiträge: 98
Registriert: 12. Apr 2010 07:23
Betriebssystem: Windows 7 Home 64bit
Produkt: DOpus 11.3
Version DOpus: Pro

Re: &-Zeichen im Button

Beitrag von Joerg765 » 21. Apr 2015 06:20

DANKE tbone, das funktioniert !!!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste