Kopieren teilweise sehr langsam

Aktuelle Version: 12.7 (23.11.2017)
Alles zum Thema Directory Opus
flashkid
Beiträge: 22
Registriert: 2. Jun 2009 15:10
Betriebssystem: Vista Home Premium 32bit
Produkt: DOpus 9.5.2.0

Kopieren teilweise sehr langsam

Beitrag von flashkid » 26. Jul 2009 16:50

Hey Leute.

Ich wollte vorhin ein paar große Dateien von meiner internen auf die externe Festplatte kopieren und merkte dabei, dass DOPUS mit < 10 MB/s kopierte.
Habe die gleiche Datei dann mit dem Windows Explorer kopiert und da lief alles mit 30 MB/s. Auch TeraCopy kopierte mit 32 MB/s.

Was kann da los sein?
Habe auch Kaspersky Anti-Virus 2009 testweise ausgemacht, auch alle sonstigen derzeit nicht benötigten Programme.
Leider kann ich nicht sagen, ob ich was verändert habe oder es immer so langsam war, aber auch eine Neuinstallation von DOPUS brachte keinen Erfolg :(

Gruß, flashkid

Benutzeravatar
Support
Site Admin
Beiträge: 3100
Registriert: 5. Apr 2003 14:21
Betriebssystem: Windows 7 & 10
Produkt: DOpus 11/12, R-Studio 8, Sawmill 8, RDI 6, MindGenius 6
Version DOpus: Pro
Wohnort: Frankfurt
Kontaktdaten:

Re: Kopieren teilweise sehr langsam

Beitrag von Support » 26. Jul 2009 23:10

Wenn der Virenscanner schon ausgeschaltet wurde, dann fällt mir dafür leider kein Grund ein.

Ich komme bei Directory Opus und MS Explorer auf rund 20 MB/s von SATA auf externe USB-HD.

abr
Berater
Beiträge: 783
Registriert: 10. Apr 2007 02:50
Betriebssystem: Win 10 Home 64bit
Produkt: neueste Betaversion
Version DOpus: Pro
Wohnort: Hamburg

Re: Kopieren teilweise sehr langsam

Beitrag von abr » 16. Aug 2009 05:11

Hallo! Also, ich würde empfehlen (bitte vorher ein Backup von Opus machen, also unter -> Einstellungen -> Export) in den Voreinstellungen unter -> Dateioperationen -> Kopieren von Dateien mal mit der unten aufgeführten Puffergrösse herumzuexperimentieren, also andere Werte zu testen (am besten wohl immer vielfache von 2, also, 4, 8, 16, 128 etc.). Aus ähnlichen Berichten im englischen Forum weiß ich, daß dies manchmal eine Beschleunigung des Kopiervorgangs brachte.

Benutzeravatar
Horst-G
Beiträge: 284
Registriert: 13. Nov 2007 17:38
Betriebssystem: Win 8.1 Pro 64 bit
Produkt: DOpus 11.1 64 bit
Version DOpus: Pro
Wohnort: BiH Banja Luka

Re: Kopieren teilweise sehr langsam

Beitrag von Horst-G » 16. Aug 2009 16:20

Du hast recht, habe meinen Wert auf 4096 erhöht und es geht wirklich schneller.

Wieder mal ein guter Tipp.

Danke

Horst-G.

ikarus7
Beiträge: 15
Registriert: 6. Jan 2010 19:21

Re: Kopieren teilweise sehr langsam

Beitrag von ikarus7 » 6. Jan 2010 19:24

Hatte dasselbe Problem,
Variationen der Puffergröße haben mir nicht geholfen.
Als ich in den Optionen bei "fortschrittsanzeigen" jedoch die option "dateien vor dem kopieren zählen" deaktivierte,
kam ich von ~11 MB/s wieder auf 25 MB/s.
Vielleicht kann dieses Problem ja von den Programmierern behoben werden.
Grüße,
Ikarus

abr
Berater
Beiträge: 783
Registriert: 10. Apr 2007 02:50
Betriebssystem: Win 10 Home 64bit
Produkt: neueste Betaversion
Version DOpus: Pro
Wohnort: Hamburg

Re: Kopieren teilweise sehr langsam

Beitrag von abr » 7. Jan 2010 17:13

Das sollte in der neuen Version (bitte erst morgen herunterladen) behoben sein.

Benutzeravatar
Horst-G
Beiträge: 284
Registriert: 13. Nov 2007 17:38
Betriebssystem: Win 8.1 Pro 64 bit
Produkt: DOpus 11.1 64 bit
Version DOpus: Pro
Wohnort: BiH Banja Luka

Re: Kopieren teilweise sehr langsam

Beitrag von Horst-G » 7. Jan 2010 20:12

Das wäre ja Super! :lol: :roll:

Benutzeravatar
Horst-G
Beiträge: 284
Registriert: 13. Nov 2007 17:38
Betriebssystem: Win 8.1 Pro 64 bit
Produkt: DOpus 11.1 64 bit
Version DOpus: Pro
Wohnort: BiH Banja Luka

Re: Kopieren teilweise sehr langsam

Beitrag von Horst-G » 8. Jan 2010 15:42

Hallo,

beim Kopieren auf einen Memorystick Scandisk Cruzer 8 GB, hat sich nichts getan was die Geschwindigkeit angeht.

ist immer noch sehr langsam.

Das geht mit dem Explorer wesentlich flotter.
Dateianhänge
Copy 2.jpg
Copy.jpg

Benutzeravatar
Nobmen
Boardbetreuer
Beiträge: 2827
Registriert: 26. Jun 2004 08:48
Betriebssystem: Win 10 Home/Pro 32/64bit
Produkt: DOpus 12.x + Betas
Version DOpus: Pro

Re: Kopieren teilweise sehr langsam

Beitrag von Nobmen » 8. Jan 2010 15:56

win7?
der windowsexplorer schreibt,wenn diese kopieranzeige weg ist, nachträglich daten auf die laufwerke,
deswegen anzeige höher!

sind für extrene geräte die optionen in w7 des schreibcache richtig gesetzt?
(alle geräte waren bei mir auf aufsicherheit gesetzt = niedrige geschwindigkeit und stockenende übertragung)

Benutzeravatar
Horst-G
Beiträge: 284
Registriert: 13. Nov 2007 17:38
Betriebssystem: Win 8.1 Pro 64 bit
Produkt: DOpus 11.1 64 bit
Version DOpus: Pro
Wohnort: BiH Banja Luka

Re: Kopieren teilweise sehr langsam

Beitrag von Horst-G » 8. Jan 2010 17:03

Ich verwende Windows 7 Ultimate 64 bit Build 7600.

Bei mir ist alles richtig eingestellt.

Kann sein, das der Explorer im Hintergrund weiter arbeitet, was mir aber egal ist, da ich genug Speicher und CPU Power habe. Gefühlt, ist er um Längen schneller.

Mit anderen Worten, ich kann auch schneller weiterarbeiten, da DOpus ziemlich viel RechnerPower beim Kopieren oder verschieben benötigt. Und das nicht nur auf externe Speichermedien, sondern auch bei internen Festplatten.
Dateianhänge
08.01.png

Benutzeravatar
Support
Site Admin
Beiträge: 3100
Registriert: 5. Apr 2003 14:21
Betriebssystem: Windows 7 & 10
Produkt: DOpus 11/12, R-Studio 8, Sawmill 8, RDI 6, MindGenius 6
Version DOpus: Pro
Wohnort: Frankfurt
Kontaktdaten:

Re: Kopieren teilweise sehr langsam

Beitrag von Support » 9. Jan 2010 14:46

Horst-G: Die Werte in den Screenshots würden ja bedeuten, dass der Windows Explorer 15x schneller ist. Ich habe es gerade einmal mit Windows XP getestet und dort ist Directory Opus schneller als der Explorer.

Meine Rate liegt aber selbst bei Directory Opus nur bei rund 15 MB/Sek. Im Screenshot zeigt der Explorer einen Wert von 90 MB/Sek. Maximal technisch möglich sind bei USB 2.0 aber nur 60 MB/Sek. Entweder ist es schon der neue USB 3.0 oder der Explorer meint MBit und nicht MByte. Auf jeden Fall ist hier etwas falsch.

Benutzeravatar
Horst-G
Beiträge: 284
Registriert: 13. Nov 2007 17:38
Betriebssystem: Win 8.1 Pro 64 bit
Produkt: DOpus 11.1 64 bit
Version DOpus: Pro
Wohnort: BiH Banja Luka

Re: Kopieren teilweise sehr langsam

Beitrag von Horst-G » 10. Jan 2010 23:25

Support hat geschrieben:Horst-G: Die Werte in den Screenshots würden ja bedeuten, dass der Windows Explorer 15x schneller ist. Ich habe es gerade einmal mit Windows XP getestet und dort ist Directory Opus schneller als der Explorer.

Meine Rate liegt aber selbst bei Directory Opus nur bei rund 15 MB/Sek. Im Screenshot zeigt der Explorer einen Wert von 90 MB/Sek. Maximal technisch möglich sind bei USB 2.0 aber nur 60 MB/Sek. Entweder ist es schon der neue USB 3.0 oder der Explorer meinz MBit und nicht MByte. Auf jeden Fall ist hier etwas falsch.
Wie gesagt, der Explorer "fühlt" sich einfach schneller an.

Ich verwende Windows 7 64 Bit Ultimate.

Wie es mit XP läuft interessiert mich nicht, da ich es schon seit Jahren nicht mehr verwende.

Benutzeravatar
Support
Site Admin
Beiträge: 3100
Registriert: 5. Apr 2003 14:21
Betriebssystem: Windows 7 & 10
Produkt: DOpus 11/12, R-Studio 8, Sawmill 8, RDI 6, MindGenius 6
Version DOpus: Pro
Wohnort: Frankfurt
Kontaktdaten:

Re: Kopieren teilweise sehr langsam

Beitrag von Support » 10. Jan 2010 23:55

Horst-G: Ich wollte nicht mit Windows XP nerven, habe aber im HomeOffice kein Windows 7 nativ laufen und der Test in einer virtuellen Umgebung macht wohl kam Sinn. Nichtsdestotrotz sind Ihre Werte unter Windows 7 mit dem Explorer so nicht realistisch und das liegt nicht daran, dass Windows 7 so viel schnell ist als XP. Gefühlte Werte sind leider auch nicht viel Wert, da man Gefühle leicht manipulieren kann, allein eine subjektiv attrativere Verlaufanzeige kann das beeinflussen. Wirklich aussagekräftig ist natürlich nur eine externe Messung, z.B. mit einer normalen Stoppuhr :)

abr
Berater
Beiträge: 783
Registriert: 10. Apr 2007 02:50
Betriebssystem: Win 10 Home 64bit
Produkt: neueste Betaversion
Version DOpus: Pro
Wohnort: Hamburg

Re: Kopieren teilweise sehr langsam

Beitrag von abr » 10. Jan 2010 23:59

Ja, würde ich auch mal sagen. Einfach mal nachmessen, wieviele Sekunden das wirklich sind, unter gleichen Bedingungen. Ich hab hier etwa 30MB/s auf eine externe Festplatte. Es kann auch langsamer sein, wenn viele kleine Dateien kopiert werden.

Edit: In Vista gab es doch sowieso ein Problem mit Kopiergeschwindigkeiten, wenn ich mich recht entsinne. Ich selber hatte ja nie Vista. Gibt es da nicht mindestens zwei Servicepacks?

Benutzeravatar
Horst-G
Beiträge: 284
Registriert: 13. Nov 2007 17:38
Betriebssystem: Win 8.1 Pro 64 bit
Produkt: DOpus 11.1 64 bit
Version DOpus: Pro
Wohnort: BiH Banja Luka

Re: Kopieren teilweise sehr langsam

Beitrag von Horst-G » 11. Jan 2010 21:44

Habe mich wirklich mal mit der Stoppuhr hingesetzt, was ich ja eigentlich gar nicht mag.

Probiert habe ich die ganze Prozedur mit einem Memorystick ScanDisk Cruzer 8 GB und einem Kingston DataTraveler 8 GB.

Verwendet habe ich verschiedene Dateiformate und Größen, mit und ohne Virenscanner.

Der Unterschied zwischen dem Win-Explorer und DOpus ist sehr unterschiedlich. Manchmal ist der Explorer schneller manchmal DOpus.

Woran da genau liegt, kann ich nicht sagen. Der Virenscanner, wenn aktiv wirkt sich bei beiden gleich (negativ oder vielleicht sogar positiv) aus.

Aber das ist alles halb so schlimm. Ich kopiere oder verschiebe ja nicht den ganzen Tag Dateien und wenn, dann nur kleinere Mengen.

Hätte aber nichts dagegen, wenn es schneller gehen würde.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste