Seite 1 von 1

Problem mit HTTP Log Source

Verfasst: 28. Jun 2005 11:13
von smaholic
Hallo,

immer wenn ich als Hostnamen die IP des Proxyserver angebe
und den Pfad auf squidlog setzte bekomme ich folgende Fehlermeldung:
Sawmill Error
Error getting file squidlog on server: server said "HTTP/1.1 400 Bad Request"

; Error occurred at: : //tulip/tulip1/sawmill/v7/production/src/http_session.cpp:108;while displaying page templates.shared.matching_log_source_files.matching_log_source_files
Per Browser ist die URL: http://ip/squidlog zugänglich und ich
bekomme alle Logdateien angezeigt.
Muss ich den Pfad und den Hostname mit einem Syntax oder einer richtigen Formatierung versehen?

Gruss
smaholic

Verfasst: 28. Jun 2005 11:43
von Support
Ich sehe jetzt auch keinen Grund für das Problem, doch so wie ich Sie verstehe, können Sie ja über http://ip/squidlog zugreifen - oder müssen Sie unbedingt über die IP gehen?

Verfasst: 28. Jun 2005 11:50
von Gast
Ich muss nicht über die IP gehen,
hat sich jetzt nur angeboten.

Über den Hostname direkt geht es auch nicht:
proxy.hmwk.hessen.de

squidlog ist allerdings das Verzeichnis und kein Dateiname.

Danke.

smaholic

Verfasst: 28. Jun 2005 14:18
von Support
Ich bin nicht sicher, ob man ein Verzeichnis angeben kann. Wenn man den Dateinamen direkt angibt funktioniert es aber. Ich erkundige mich beim Hersteller danach.

Verfasst: 28. Jun 2005 15:52
von smaholic
Das kann gut sein.
Allerdings geht es ja auch von einem Lokalem Datenträger (Verzeichnis)

Wie müsste ich den Pfad angeben wenn ich eine einzelne Datei einlesen wollte?
Hostname: testpc
Pfad: squidlog/access.log

?

Verfasst: 29. Jun 2005 13:59
von Support
Der Grund, warum man über HTTP kein Verzeichnis angeben kann, ist, dass HTTP keine mehrfachen GET-Befehle unterstützt. Man muss daher entweder per FTP zugreifen oder mehrere Logquellen angeben oder die Dateien manuelle auf die Festplatte laden.